Exercícios de Matriz. Usando o VisualG

Facebooktwittergoogle_plusredditpinterestlinkedinmailby feather

Concluir a resolução dos sete exercícios passado pelo Prof.. Jonatas sobre Matriz.Cada um me consumiu uma certa quantidade de tempo. Depois de resolvido é que se pode ver como é simples fazer. Programar é encontrar caminhos, meios, de se fazer.

Para testar no VisualG, é só copiar e colar o código dos exercícios. Porém é recomendado que cada um estude e saiba fazer o código para fixação da rotina e da solução dos exercícios propostos.

Parece-me que é proibido publicar na internet respostas dos exercícios pois, não encontrei nenhum blog, fórum em que se possa ter respostas para os exercícios, nem para facilitar, então, como fonte de auxilio, eis abaixo, em pseudo-código: portugol, programado em VISUALG os seguintes exercícios.

1. Faça um algoritmo para ler uma matriz de 3×4 de números reais e depois exibir o elemento do canto superior esquerdo e do canto inferior

algoritmo “Estudando Matriz”

// Função : Faça um algoritmo para ler uma matriz de 3×4 de números reais
// e depois exibir o elemento do canto superior esquerdo e do canto inferior direito
// Autor : Adão Braga
// Data : 26/6/2011
// Seção de Declarações

var
matriz : vetor[1..3,1..4] de real
i,j:inteiro

inicio
// Seção de Comandos

para i de 1 ate 3 faca
para j de 1 ate 4 faca
escreva(“Digite um número inteiro: [“, i, “,”, j, “] “)
leia(matriz[i,j])
fimpara
fimpara

para i de 1 ate 3 faca
para j de 1 ate 4 faca
escreva(matriz[i,j]:3)
fimpara
escreval(“”)
fimpara
escreval(“”)
escreval(“linha 1 e coluna 1”, matriz[1,1])
escreval(“linha 3 e coluna 4”, matriz[3,4])

fimalgoritmo

2. Ler uma matriz 5X5 e gerar outra em que cada elemento é o cubo do elemento respectivo na matriz original. Imprima depois o elemento do meio desta nova matriz;

algoritmo “Criar Matriz 5×5 e elevar ao cubo”
// Função Ler uma matriz 5X5 e gerar outra em que cada elemento é o cubo
// do elemento respectivo na matriz original.
// Imprima depois o elemento do meio desta nova matriz;
// Autor : Adao Braga
// Data : 26/6/2011
// Seção de Declarações
var
vetA:vetor[1..5,1..5] de real
vetB:vetor[1..5,1..5] de real
i,j:inteiro

inicio
// Seção de Comandos

para i de 1 ate 5 faca
para j de 1 ate 5 faca
escreva(“Digite os numeros: [“,i, ” + “, j, ” ] “)
leia(vetA[i,j])
fimpara
fimpara

para i de 1 ate 5 faca
para j de 1 ate 5 faca
escreva(vetA[i,j]:7)
fimpara
escreval(“”)
fimpara

para i de 1 ate 5 faca
para j de 1 ate 5 faca
vetB[i,j]<- (vetA[i,j]^3)
fimpara
fimpara

para i de 1 ate 5 faca
para j de 1 ate 5 faca

          escreva(vetB[i,j]:7)

     fimpara
escreval(“”)
fimpara

fimalgoritmo

3. Faça um algoritmo para ler uma matriz 2X3 real e depois gerar e imprimir sua transposta (matriz 3X2 equivalente);

algoritmo “Matriz: TRANSPORTA”

// Função : Faça um algoritmo para ler uma matriz 2X3 real e depois gerar
// e imprimir sua transposta (matriz 3X2 equivalente);
// Autor : Adão Braga
// Data : 26/6/2011
// Seção de Declarações

var
matrizA : vetor[1..2,1..3] de real
matrizB : vetor[1..3,1..2] de real
i,j:inteiro

inicio
// Seção de Comandos

para i de 1 ate 2 faca
para j de 1 ate 3 faca
escreva(“Digite um número inteiro: [“, i, “,”, j, “] “)
leia(matrizA[i,j])
fimpara
fimpara

escreval(” ———-  MATRIZ A ———-“)
para i de 1 ate 2 faca
para j de 1 ate 3 faca
escreva(matrizA[i,j],” “)
fimpara
escreval(” “)
fimpara

para i de 1 ate 3 faca
para j de 1 ate 2 faca
matrizB[i,j]<-(matrizA[j,i])
fimpara
fimpara

escreval(” ———-  MATRIZ B ———-“)
para j de 1 ate 3 faca
para i de 1 ate 2 faca
escreva(matrizB[j,i],” “)
fimpara
escreval(” “)
fimpara
escreval(” ——————–“)

fimalgoritmo

4. Faça um algoritmo para ler uma matriz 3X3 real e imprimir a soma dos elementos da Diagonal principal.  Generaliza para uma matriz NXN;

algoritmo “Matriz 3×3 Somar Diagonal”
// Função Faça um algoritmo para ler uma matriz 3X3 real e imprimir
// a soma dos elementos da Diagonal principal. Generaliza para uma matriz NXN;
// Autor : Adao Braga
// Data : 26/6/2011
// Seção de Declarações
var
matrizA:vetor[1..3,1..3] de real
somaDiag1:real
i,j:inteiro

inicio
// Seção de Comandos

para i de 1 ate 3 faca
para j de 1 ate 3 faca
escreva(“Digite os numeros: [“,i, ” + “, j, ” ] “)
leia(matrizA[i,j])
fimpara
fimpara

para i de 1 ate 3 faca
para j de 1 ate 3 faca
escreva(matrizA[i,j])
fimpara
escreval(“”)
fimpara

para i de 1 ate 3 faca
para j de 1 ate 3 faca
somaDiag1<-(matrizA[1,1] + matrizA[2,2] + matrizA[3,3])
fimpara
fimpara
escreval(“—————————————“)
escreval(“Soma da Diagonal 1 é = “, somaDiag1)
escreval(“—————————————“)
fimalgoritmo

5. Ler uma matriz 4X3 real e imprimir a soma dos elementos de uma linha L fornecida  pelo usuário;

algoritmo “Criar Matriz 4×3 Somar Linha”
// 5. Ler uma matriz 4X3 real e imprimir a soma dos elementos de uma linha L fornecida pelo usuário
// Autor : Adao Braga
// Data : 30/6/2011
// Seção de Declarações
var
vet4x3:vetor[1..4,1..3] de real
linha,i,j:inteiro
SomarLinha:real

inicio
// Seção de Comandos

para i de 1 ate 4 faca
para j de 1 ate 3 faca
escreva(“Digite os numeros: [“,i, ” + “, j, ” ] “)
leia(vet4x3[i,j])
fimpara
fimpara
escreva(” “)

escreval(” ———-  MATRIZ  4 X 3 ———-“)
para i de 1 ate 4 faca
para j de 1 ate 3 faca
escreva(vet4x3[i,j],” “)
fimpara
escreval(” “)
fimpara
escreval(” ——————–“)

escreva(“Qual linha quer somar? “)
leia(linha)

somarlinha<-0

para i de linha ate linha faca
para j de 1 ate 3 faca
somarlinha <- somarlinha + vet4x3[linha,j]

     fimpara
fimpara

escreval(“Linha somada.: “, linha)
escreval(“Total da soma da linha: “, somarlinha)

fimalgoritmo

6. Ler uma matriz 4X3 real. Depois, mostre qual é o elemento armazenado em uma linha e coluna C fornecidos pelo usuário;

algoritmo “Matriz 4×3 Mostrar dados solicitado”
// 6. Ler uma matriz 4X3 real. Depois, mostre qual é o elemento armazenado
// em uma linha e coluna C fornecidos pelo usuário;
// Autor : Adao Braga
// Data : 30/6/2011
// Seção de Declarações
var
vet4x3:vetor[1..4,1..3] de real
linha,coluna,i,j:inteiro

inicio
// Seção de Comandos

para i de 1 ate 4 faca
para j de 1 ate 3 faca
escreva(“Digite os numeros: [“,i, ” + “, j, ” ] “)
leia(vet4x3[i,j])
fimpara
fimpara
escreva(” “)

escreval(” ———-  MATRIZ  4 X 3 ———-“)
para i de 1 ate 4 faca
para j de 1 ate 3 faca
escreva(vet4x3[i,j],” “)
fimpara
escreval(” “)
fimpara
escreval(” ——————–“)

escreva(“Qual linha você quer ver? “)
leia(linha)

escreva(“Qual coluna quer ver? “)
leia(coluna)

para i de linha ate linha faca
para j de coluna ate coluna faca
escreval(“O numéro armazenado na linha “,linha, ” e na coluna “,coluna, ” é: “, vet4x3[linha,coluna])
fimpara
fimpara

fimalgoritmo

7. Crie uma matriz 7X8 onde cada elemento é a soma dos índices de sua posição dentro da matriz;

algoritmo “Matriz 7×8 soma de seus indices”
// 7. Crie uma matriz 7X8 onde cada elemento é a soma
// dos índices de sua posição dentro da matriz;
// Autor : Adao Braga
// Data : 30/6/2011
// Seção de Declarações
var
vet7x8:vetor[1..7,1..8] de inteiro
i,j:inteiro

inicio
// Seção de Comandos

para i de 1 ate 7 faca
para j de 1 ate 8 faca
vet7x8[i,j]<-i+j
fimpara
fimpara

para i de 1 ate 7 faca
para j de 1 ate 8 faca
escreva(vet7x8[i,j],” “)
fimpara
escreval(” “)
fimpara

fimalgoritmo

Facebooktwittergoogle_plusredditpinterestlinkedinmailby feather
NELSON ZANOTTI JUNIOR
O exercício número 04 não está funcionando direito, dá erro na linha onde tem somadiagl<-(matrizA….., queria saber qual é o problema. Agradeço, Nelson.
Raul
Tem como eu escrever uma matriz fora do “para”? minha professora falou q se eu botasse: ‘escreval (“matriz: “,M[i,j])’ fora do “para” iria imprimir todos os valores da matriz. Só q eu testei aki e n ta funcionando, tem como fazer isso? Se sim, oq eu to fazendo de errado?
Luccas
Ola eu to montando um restaurante e eu gostaria de saber como faz um programa tipo cardapio.
tipo assim elle deve fornecer o menu de comidas e precos, ai fazer um ou mais pedidos pedido para o cliente. depois que o cliente fazer o pedido, ele somar e dar o valor total da compra. sera que eh possivel?

tipo assim
cardapio

1-lasanha—————–x valor
2-arroz——————–y valor
3-refi———————–z valor
4-pudim———————–w valor

faca seu pedido:
1, 2, 3

total a pagar:
x+y+z=?

hallysson
adão, parabéns pela iniciativa. Eu tava quebrando a cabeça em como gerar uma matriz composta. Perfeito!
hallysson
raul, o visualg não vai encontrar nenhum índice do vetor fora do para.
por isso existe o ‘para i de…'(“i” ou outra variável de controle).
nesse seu exemplo pode-se fazer o seguinte…em uma matriz 3×3, após fazer a leitura dos valores:
‘escreval(“matriz:”) //fora do ‘para’
para i de 1 ate 3 faca
para j de 1 ate 3 faca
escreva(m[i,j])
fimpara
fimpara’
*Se vc colocar o ‘escreval(“matriz:”,m[i,j])’ dentro do ‘para’, ele vai repetir a mensagem pra cada valor da matriz por causa do loop de repetição, o que é desnecessário.
falow!
Douglas Bik
Boa Tarde
meus amigos
Gostei muito desta pagina vou indicar aos meus colegas,
mas tenho uma questao que nao estou conseguindo fazer para um trabalho, se puder me ajudar agrdeço muito.

Faça um algoritmo que leia uma matriz 3×3 e caso exista
calcule a sua matriz inversa, senão mostre uma mensagem ao usuário dizendo
que a matriz inversa não existe.

Obrigado e fico no aguardo, Douglas

Fabio
Amigo,

Estou com dificuldades em 2 exercicio de algoritimo, gostaria se possivél que você me ajudasse. Desde ja agradeço.

Faça um algoritmo (pseudocódigo), em seguida, programa em C++ que preencha dois vetores de 10 posições cada um, determine e mostre um terceiro contendo os elementos ímpares dos dois vetores anteriores ordenados de maneira decrescente.

4 – Faça um algoritmo e em seguida, um programa em C++ que: preencha uma matriz 4 X 8 de inteiros, calcule e mostre a média dos elementos das linhas pares da mesma.

Fábio. Ai nestes exemplos tem códigos suficientes para você desenvolver estes exercícios ai. Se não, bem! Tem outros exemplos neste blog: http://subsequenteirece.blogspot.com, e também tem mais no scridb.com com o usuário Adao Braga

Fabio
OK, um conseguir ja o outro ta complicado.

Faça um algoritmo (pseudocódigo), em seguida, programa em C++ que preencha dois vetores de 10 posições cada um, determine e mostre um terceiro contendo os elementos ímpares dos dois vetores anteriores ordenados de maneira decrescente.

rony
Crie um programa que receba as vendas semanais (de um mês) de três vendedores de
uma loja e armazene essas vendas em uma matriz. O programa deverá calcular e mostrar:
a. O total de vendas do mês de cada vendedor;
b. O total de vendas de cada semana (todos os vendedores juntos);
c. O total de vendas do mês.

por favor me ajude

jessica
Crie um algoritmo que preencha uma matriz 5 x 5 e depois apresente na tela os
valores da matriz
magno
alguem consegue me ajudar?

crie um algoritimo no visualg que
1 guarde uma matriz de valores reais , com indice de 1 ate 4 e de 1 ate 5.
2 exiba uma msg na tela que solicite a entrada de uma matriz de numeros reais.
3 receba estes valores repetitivamente dentro de um conjunto de processos do tipo para consecutivo.
4 analisar cada um destes valores e os indices que controlam os 2 processos para avaliado: se o primeiro e o segundo indice tiverem o mesmo valor, avaliar se o numero real tem um valor nulo; se for verdadeiro o caso guardar o valor como sendo 1.
5 exibir estes valores repetitivamente dentro de um conjunto de processos do tipo paraconsecutivo, exibindo alem do valor os indices para correspondente

Adão Braga
Não faço exercícios de VisualG, a não ser, se a escola exigir.
Os exemplos dados, são suficientes para elaborar sua resposta!
Boa sorte!
Marcelo
Parabéns pelos exemplos apresentados, serão muito úteis em nossa instituição …
Ronnyê Lima
Olá, gostaria primeiramente de parabeniza-lo pela iniciativa, realmente é muito difícil encontrar exercícios resolvidos neste programa que é base no estudo da lógica de programação. Fiquei com uma dúvida no último exemplo… posso estar enganado, mas acho que os a soma dos índices deveriam ser feito assim: ” vet7x8[i,j]<-J+i ", pois desta forma estaria somando os índices J e I, e não apenas o 'I', como está sendo apresentado. Apenas detalhe, coisa de uma letra, que como ja falei, não sei se estou certo. Mas parabéns pela iniciativa =D
Júanice Carrilho
Gostaria que alguém me ajudasse nesta questão.

Para a matriz M(5×5) de inteiros.Escrever um programa capaz de:
a) Ler os elementos para matriz
b) Identificar o número de elemento iguais a zero em cada uma das linhas.
c) Identificar o número de elementos iguais a zero em cada uma das colunas.
d) Calcular a média aritmética dos elementos de cada uma das linhas e armazenando esses valores em um vetor.
e) Identificar a linha que tem a maior media de seus elementos.
f) Determine a matriz transposta T de M (Obs: T[i][j]= M[j][i]).
g)Imprimir todos os resultados.

Adão Braga
Nos exemplos acima citado, se não me engano, tem tudo isto ai já respondido.
É só adaptar, agregar, ajuntar tudo em um só algoritmo.
Bernardo
Boa noite gostaria que alguém pudesse me ajudar a resolver essa questão preciso muito de ajuda, sou iniciante de IP e tenho pouca noção.obrigado

Questão:
Faça um algoritmo para ler uma matriz 3×3 de números inteiros e imprimir quantos números ímpares e quantos números pares foram armazenados na matriz.

Daiane
Pelo amor de Deus, me ajude a resolver essa questão : Faça um algoritmo para ler uma matriz e escrever apenas os elementos que aparecem mais de uma vez.
José Henrique
Bom dia,

Gostei muito da sua transposição do livro “Algoritmos Programação Para Iniciantes” do autor Gilvan Vilarim. Só não me agradou seu nome como autor das questões citadas acima.

Abraços

Adão Braga
Deixe-me lista:
1- Não li o livro citado: “Algoritmos Programação Para iniciantes”;
2- Não copiei, não fiz plágio, não tive acesso aos códigos do Gilvan Vilarim;
3- Se tivesse feito a “transposição do livro”, tenho dignidade suficiente para fazer a citação ao autor;
4- Se está meu nome como autor, é por que eu sou o autor; eu fiz os códigos; dediquei tempo, energia, e estudo.
5- Ainda que os exercícios tenham sido copiados do livro, pode ser que o professor do IFBA-Irecê, o tenha feito, EU NÃO TIVE acesso ao livro e aos códigos que possam lá existir;
Francis Leonardi
Olá
estou com dificuldade para resolver uma questão e queria saber se teria como você me ajudar (mandar o passo a passo. Aqui está.
Crie um algoritmo em visualg que leia duas matrizes 2×5 e crie uma terceira matriz também 2×5 com o valor da soma dos elementos de mesmo índice.
Desde já, agradeço…
wesley
ola estou cm dificuldade em resolver uma questao tem como vocês mi ajudarem.Aqui esta.
Faca um algoritmo usando matriz (16×6)e escolha uma célula para calcular e imprimir o fatorial de um numero e ainda retorne o nome do usuario que informou o numero:
Adão Braga
Esta semana não tenho muito tempo para solucionar.
Dou uma dica: use os exemplos do texto, e copie o código de fatorial e tá resolvido.

Se você não conseguir até sábado, entre em contato!

uanderson nunes
crie duas matrizes A 4 x 4 e B 4 x 4 e depois criar uma matriz MAIOR 4 x 4 para receber os maiores das doas matrizes.
Alguém se garante.
uanderson nunes
crie duas matrizes A 4 x 4 e B 4 x 4 e depois criar uma matriz MAIOR 4 x 4 para receber os maiores das doas matrizes.
Alguém se garante.
-/hellemn Cardoso
Crie um programa que preencha uma matriz A 4×5 e uma segunda matriz B 5×2. O programa deverá, também, calcular e mostrar a matriz resultante do produto da duas matrizes A e B, mostrando-os numa matriz resultante R 4×2.

1. Na teoria de Sistemas define-se como elemento mínimax de uma matriz, o menor elemento da linha em que se encontra o maior elemento da matriz. Escrever um algoritmo que lê uma matriz A de ordem N e determine o elemento mínimax desta matriz, escrevendo a matriz A e a posição (linha,coluna) do elemento mínimax.
2. Uma matriz quadrada é dita simétrica se para todo i e j, o elemento (i, j) é sempre igual ao elemento (j,i). Escrever um algoritmo que verifica se uma matriz é ou não simétrica.
4. Escrever um algoritmo que gera os 10 primeiros números primos acima de 100 e os armazena em um vetor X[10] escrevendo, no final, o vetor X.

Alguém pode ajudar-?

Adão Braga
Estou ocupadíssimo com os portfólios para preparar e dois TCC para formatar.
Posso fazer não! Exceto, se uma proposta financeira muito atraente acompanhar o pedido
a ponto, de eu ter que deixar as tarefas
letsc
como eu faço isso??

1) Fazer um algoritmo que simule um controle de estoque

Requisitos

I) O algoritmo deverá conter uma matriz que comporte 5 produtos, seu código (inteiro), seu estoque inicial, seu valor de venda (inteiro), seu estoque atual. A Matriz será de 5 linhas por 4 colunas, cada linha será um produto, e cada coluna será, respectivamente, o código, a descrição do produto, estoque inicial, preço de venda e estoque atual

II) Uma matriz que concentre quantidade das vendas dos produtos e o valor acumulado dessas vendas. Essa matriz será de cinco linhas e tres colunas, cada linha será relacionada ao produto de mesmo número de linha, na matriz, anterior, e as colunas serão, a quantidade de vendas, e o valor acumulado

III) Um vetor de cinco posições, no qual ficarão guardadas a reposição dos estoques.

Operações

O algoritmo deve ter um menu, onde o usuário possa escolher:

a) vender um produto, informando a quantidade desejada, do mesmo;
b) listar o estoque, mostrando o código do produto e a quantidade atual do estoque;
c) listar a matriz de vendas, apresentando a quantidade de produtos vendidos e o valor das vendas;
d) verificação de estoque baixo, que é uma função que vai listar os produtos que estiverem com estoque atual menor ou igual a 20% do estoque inicial;
e) reposição de estoque, que é uma função que permite que o usuário atualize os estoques dos produtos em baixa.

– O algoritmo deverá possibilitar a entrada e saída de produtos, verificando se é possível atender ao pedido, a partir da disponibilidade do estoque. (a) e (e)

– O algoritmo deve permitir que se vendam produtos, atualizando o estoque atual e a matriz de venda (b)

– o algoritmo deve atualizar a matriz de vendas com a quantidade de produtos vendidos e o valor acumulado dessas vendas (c)

– Implementar uma função que verifique os estoques atuais de todos os produtos. Quando o estoque atual chegar a 20% do estoque inicial (ou menos) deve ser dado um alerta de compra de produtos, o qual deve ser armazenado no vetor de reposição, de forma não acumulativa. Cada aquisição de reposição deve atualizar o estoque atual. (d) e (e)

Hul
Como faço para multiplicar os valores de uma matriz [100][2] (multiplicar a coluna 1 pela coluna 2)?
Hellen
Faça um algoritmo que auxilie um professor, solicitando que digite o nome de 5 alunos e a média de cada aluno, posteriormente mostre em forma de tabela (matriz) o nome de cada aluno e suas respectivas notas.

utilizando o visualg

Jose Melo
Preciso do apoio para resolver estes exercícios:
1) Leia do usuário 10 inteiros e exiba-o na ordem inversa da entrada.
2) Construir um arquivo com 1.000 inteiros entre 1 e 10, calcular e exibir o seu histograma.
3) Listar os 10 primeiros números da sequência de Fibonacci de ordem 5, ou seja, um número é determinado pela soma dos 5 números anteriores.
nathaly cristiane chuvistak
2) Ler uma matriz de ordem 3 formada por elementos inteiros e:
a) Calcular a soma de todos os elementos
b) Calcular a soma da linha 1
c) Encontrar o menor elemento da matriz e a posição em que o mesmo se encontra
alguem pode me ajudar??
Fernando Pacheco
Olá Bom dia Adão!
Você poderia me ajudar a como resolver esse exercício:

Crie um vetor NOME, tipo caracter, tamanho 5, para guardar os nomes;
2. Crie uma matriz NOTA, tipo real, de tamanho (5×3), para guardar as notas;
3. Crie 3 vetores: MAIOR_NOTA, MENOR_NOTA, e MEDIA, tipo real, tamanho 5, para guardar as maiores notas, menores notas, e médias de cada aluno;
4. Crie um vetor PERC_FALTA, tipo real, tamanho 5, para guardar os percentuais de falta;
5. Crie um vetor SITUACAO, tipo caracter, tamanho 5, para guardar a situação dos alunos: aprovado ou reprovado. O aluno será aprovado se tiver média maior ou igual a 6, e percentual de faltas menor ou igual a 25%.
6. Leia nome, número de faltas, e notas de cada aluno;
7. Calcule e escreva a maior nota, a menor nota, e a média de cada aluno;
8. Calcule e escreva o percentual de faltas de cada aluno, sabendo que o número de aulas no total foi 40;
9. Calcule e escreva a situação de cada aluno;
10. Exiba ao final as informações

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *