=SOMA(A1>=A2;3;C1:C3)

A fórmula =SOMA(A1>=A2;3;C1:C3) aplicada ao fragmento de planilha eletrônica abaixo resulta em 12. O problema é entender o porque da resposta.  Mas, agora depois de analisada, fica fácil de entender. Vou separar a fórmula para explicar.

fragmento-excel

=SOMA(A1>=A2 … ) esta parte da fórmula pode ter apenas duas resposta que são:

  1. Se for verdadeira, ou seja, se A1 contém um número maior ou igual a A2 o resultado é igual a 1 e será somado com 3+C1:C3
  2. Se for falso, ou seja, se A1 contém um número menor ou igual a A1, o resultado é igual a 0 (zero) e será somado com 3+C1:C3

Soma-se 1 + 3, mais a soma do intervalo de células C1:C3 e o resultado é igual a 12. Fica assim, armado e efetuado:

RESULTADO
=SOMA(A1>=A2) gera 1 de resposta 1
Mais o número 3 que está inserido 3
Soma do Intervalo C1:C3 8
Resultado 12

Faça o teste no Excel ou no Calc que você vai entender a resposta. Mude os números de A1 e A2.